Issues found

1. Color theme issue  XE-807

  • When creating a New Color theme, the wizard asks for a name. That name is only used for the name of the document, not for the title. So basically when you create a new theme named Test, you will bet a Test document, but the title is blank. This will result in something like :
  • xe30ColorTheme.png

2. Send Page By Email close icon badly rendered in IE6

xe30sendpagebyemailIE6.png

3. Deprecated methods used

  •  Deprecated usage of method [com.xpn.xwiki.XWiki.copyDocument]
  • 2011-01-17 15:49:04,688 [http://192.168.2.13:8080/xwiki/bin/view/IE6Space/IEtF] WARN  internal.DefaultVelocityEngine  - Deprecated usage of method [com.xpn.xwiki.api.XWiki.parseMessage] in @18,8

4. Rights UI is not consistent (On a page, select Edit Rights)

XE30Rights.png

5. WYSIWYG Iframe badly rendered in User Profile (IE 7)

XE30UserProfileIE7.png

6. After adding an attachment, the tab is moved back to Comments (IE7 and IE6)

7. JS Error when clicking on a link to a non existing page (IE7 and IE6)

XE30IE7Link.png

8. Watch Button (Wiki, Space, Page) won't update (become yellow) until page refresh (not AJAX behavior). Same with Un-watch. (Happens on IE7 and IE6)

9. WYSIWYG Editor -> Insert Table -> Columns and Rows don't get any input in FF (confirmed by mflorea)

10. Issues with XAADMINISTRATION (html macro error)

This happens for : Annotations, Registration, Invitation Application

Go to Administer Wiki and click Annotations.

30snapAnnotations.png

11. Blog is broken [Failed to execute velocity macro]

    

$xwiki.getDocument('Help.SupportPanel.Content').translatedDocument.title

Failed to execute the [include] macro. Cause: [Current user [incubator:XWiki.evalica] doesn't have view rights on document [xwiki:Help.SupportPanel.Content]]. Click on this message for details.