Wiki source code of 25Snapshots

Last modified by Sorin Burjan on 2010/11/05 10:25

Show last authors
1 As tested on 2.5.1
2
3
4 = Blocker Issues =
5
6
7 * NO login screen on IE 6 due to CSS break down.
8 * [[image:2.5.1IE6LoginScreen.png||style="vertical-align: top;" width="700"]]
9
10 * CSS break-down on IE7 (Blocker)
11 * [[image:2.5.1IE7MainWebHome.png||style="vertical-align: top;" width="800"]]
12 * Administration of XWiki (blocker)
13 * [[image:2.5.1IE7Administration.png||style="vertical-align: top;" width="800"]]
14
15
16 //As tested on xwiki-enterprise-jetty-hsqldb-2.5-20100901.112158-117//
17
18
19 * //Tag allows really long "word", but hasn't a limit for breaking them, and this could make the UI look bad.// This affects ALL browsers, so not an IE issue.
20 //[[image:Tag.png||style="vertical-align: middle; width: 695px; height: 174px;"]]//
21
22 * //On IE6, the rendering of the Add Tag window has a few problems. It will NOT stay like that if you hover the mouse over the 2 buttons. Hovering will redimension it to the normal size.//
23
24 |=The Clicking the [+] button|=When Typing|=When hovering over Cancel or Save button
25 |image:TagButtonClick.png |image:TagTyping.png |[[image:TagHoverOverButtons.png]]
26
27 * (((
28 Seems that chackboxes don't vertically allign middle correctly. Don't know if this is normal. Tested on FF, IE6, IE7, Chrome. Windows and Linux.
29
30 |=When editing a page|=Admin Section
31 |[[image:CheckBox1.png]]|[[image:CheckBox2.png]]
32
33 // //
34 )))
35
36 //As tested on xwiki-enterprise-jetty-hsqldb-2.5-20100830.230400-114 //
37
38 * **Buttons smaller in IE7 and not properly displayed on hover**
39
40 |= |=Button |=Button on hover
41 |=2.5 |image:ButtonIE7in25.png |[[image:HoverButtonIE7in25.png]]
42 |=2.4 |image:ButtonIE7in24.png |[[image:HoverButtonIE7in24.png]]
43
44 * **Buttons not displayed correctly in IE7 for the Wiki and Wysiwyg editor**
45
46 |=2.5 |[[image:EditWikiWysiwygIE7.png]]
47
48 * **"Edit parent" button not displayed correctly in IE8, missing in IE 6 & 7:**
49
50 |=FF |[[image:EditParentFF.png]]
51 |=IE8 |[[image:EditParentIE8.png]]
52 |=IE6 & 7 |[[image:EditParentIE67.png]]
53
54 * **Buttons not displayed correctly in IE7 when editing a blog post**
55
56 |IE7 |[[image:EditBlogPostIE7.png]]
57
58 * **"Edit" menu doesn't display correctly when editing "Objects"**
59
60 To Reproduce:
61
62 * Edit a page objects
63 * Hover over the "Edit" menu
64
65 Results:
66
67 * In IE6: The "Select a class" dropdown is displayed over the "Edit" menu
68 * In IE7: You can't click the "Class" link in the "Edit" menu
69
70 |=IE6 |[[image:EditObjectsIE6.png]]
71 |=IE7 |[[image:EditObjectsIE7.png]]
72
73 * **Summary in History for adding Attachments displays code, in addition to the attachment name**
74
75 To reproduce:
76
77 * Attach a file
78 * Click on the History tab
79 * Look at the summary for the page version where you added the attachment.
80
81 Result:
82
83 * The summary is //Upload new attachment <a href="/xwiki/bin/downloadrev/Main/WebHome/File.txt?rev=1.1">TestingPlan.txt</a>// instead of //Upload new attachment File.txt//
84
85 |[[image:AttachmentsHistory.png]]

$xwiki.getDocument('Help.SupportPanel.Content').translatedDocument.title

Failed to execute the [include] macro. Cause: [Current user [incubator:XWiki.evalica] doesn't have view rights on document [xwiki:Help.SupportPanel.Content]]. Click on this message for details.